En una gema ruby tengo una dependencia a fileutils en el gemspec.

Gem::Specification.new do |s|
#...
s.add_runtime_dependency 'fileutils'
end

Pero al instalarla con

gem install imposition-0.8.9

se cae así

Building native extensions.  This could take a while...
ERROR:  Error installing rmagick:
	ERROR: Failed to build gem native extension.

        /usr/bin/ruby1.8 extconf.rb
checking for Ruby version >= 1.8.5... yes
checking for gcc-4.6... yes
checking for Magick-config... no
Can't install RMagick 2.13.1. Can't find Magick-config

(Sólo cuando se depende de fileutils)
De hecho es lo mismo que sale si ejecutamos

sudo gem install rmagick

Para arreglarlo hay que tener el paquete libmagick9-dev >>
O en Debian, libmagick++-dev >>

sudo apt-get install libmagick++-dev

Ahora, ¿dónde avisaron de este nuevo requerimiento?
Moya… En todo caso, al parecer >>, el requerimiento es bastante viejo…

Este sitio utiliza cookies.    Leer más