Cuando tenga ud. una gema que dependa de fileutils e intente instalarla puede toparse con Mr.

sudo gem install imposition-0.9.4.5.1.gem
[sudo] password for nn:
Building native extensions.  This could take a while...
ERROR:  Error installing imposition-0.9.4.5.1.gem:
	ERROR: Failed to build gem native extension.

        /usr/bin/ruby1.9.1 extconf.rb
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- mkmf (LoadError)
	from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
	from extconf.rb:1:in `'

Somos viejos enemigos >>, se debe a que fileutils depende de rmagick (intente

gem install rmagick

…)
que al parecer dejar de mantenerlo…
Pero puede ser porque en Debian no está el paquete -dev de ruby 1.9.3, creo que lo desarrollé en 1.8 de hecho (antes de la era rvm) entonces

rvm install ruby-1.9.1-p431
rvm 1.9.1

sudo apt-get install ruby1.9.1-dev

y ésa es la versión en que rmagick funciona.

Este sitio utiliza cookies.    Leer más