En ruby 2.0 vuelve este gran amigo mío al correr

bundle install

señores, helo aquí:

Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

/home/roberto/.rvm/rubies/ruby-2.0.0-p0/bin/ruby extconf.rb
checking for libxml/parser.h... yes
checking for libxslt/xslt.h... no
-----
libxslt is missing. please visit http://nokogiri.org/tutorials/installing_nokogiri.html for help with installing dependencies.
-----
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers. Check the mkmf.log file for more details. You may
need configuration options.

que es lo mismo que sale con

gem install nokogiri -v '1.5.9'

Si miramos el link que dan, dice que en Debian/Ubuntu hay que correr

sudo apt-get install libxslt-dev libxml2-dev

para instalar las librerías que permiten compilar gemas en C (lo cual esta tal nokogiri necesita) y, efectivamente, con ésta pasa.

Ahora, me pregunto, que tiene que ver extconf con ésto, ¿por qué sale el mismo error superior cuando hay errores al instalar gemas distintas?

Este sitio utiliza cookies.    Leer más