OBS

Es un programa para emitir streaming de video, muy útil para transmitir ‘en vivo’, por ej. a las redes sociales (rr.ss). Esto, que en sus apps para celulares es muy fácil (basta con pulsar el botón rojo), en una computadora se hace con un software como éste, conectándolo a una cámara web y a su cadena de sonido.

Para ello OBS es una buena solución, permitiendo gestionar varias cámaras y pantallas y mezclarlas (estilo VTR). Acompañadándolo de una mesita de sonido, hacen todo un estudio de TV virtual. Si quieres aprender más, !Justo RadiosLibres.net sacó un tutorial acerca de OBS! demostrando cómo se puede transmitir video completamente con software libre.

OBS en Etertics

GNU Etertics es el sistema operativo (SO) de software libre para radios. Este artículo trata de cómo actualizar a la última versión de OBS en él.

En Etertics, OBS viene desde el repositorio de deb-multimedia.org, que debieran traer paquetes más nuevos que los repos de Devuan. No obstante en el caso de Etertics Kuntur trae la v. 1.19 y en en Turpial la v. 1.23, las cuales están bastante obsoletas.

No vienen compiladas con soporte para cifrado SSL/TLS o son versiones anteriores a actualizaciones necesarias para corregir bugs (leer más). Como abordaremos a continuación, esto hace que no estén al día para transmitir en las plataformas de las rr.ss, las que desde hace un tiempo requieren de este nivel de seguridad en la transmisión del streaming de vídeo.

RTMPS

Recomendamos utilizar preferentemente el software libre (SL). Sin embargo, también abordaremos en este artículo el uso del protocolo RTMP, el cual es utilizado por las plataformas privativas como Facebook Live y sus clones (Ig,Tw,etc.). Cifrado con el protocolo SSL/TLS, se transforma en RTMPS.


Soporte SSL/TLS

Si su OBS en Etertics no puede conectar con estas plataformas, es posible que se deba a que no soporta SSL. Para confirmarlo puede revisar el Log de OBS. Es accesible en la misma interfaz, arriba a la derecha donde dice Ayuda.

Si ve mensajes que dicen que no se soporta SSL/TLS, este es su caso:

09:03:00 AM.016: [rtmp stream: 'adv_stream'] Connecting to RTMP URL rtmps://live-api-s.facebook.com:443/rtmp/... 
09:03:00 AM.103: RTMP_Connect1, no SSL/TLS support 
09:03:00 AM.104: [rtmp stream: 'adv_stream'] Connection to rtmps://live-api-s.facebook.com:443/rtmp/ failed: -2 
09:03:00 AM.104: ==== Streaming Stop ================================================

También pueden haber mensajes de error de conexión:

Oct 25 18:55:16 fbc-video nautilus-classic.desktop: info: [rtmp stream: 'adv_stream'] Connecting to RTMP URL rtmps://live-api-s.facebook.com:443/rtmp/... 
Oct 25 18:55:16 fbc-video nautilus-classic.desktop: info: RTMP_Connect1, TLS_Connect failed: -0x7680 
Oct 25 18:55:16 fbc-video nautilus-classic.desktop: info: [rtmp stream: 'adv_stream'] Connection to rtmps://live-api-s.facebook.com:443/rtmp/ failed: -2

Esto se debe a que hay un bug en la cadena de verificación de los certificados, por lo tanto no se puede establecer comunicación con seguridad TLS.


Re-instalación desde las fuentes

Estos errores han sido corregidos recientemente en el código fuente de OBS.

Como las versiones que tenemos disponibles en nuestros gestores de paquetes son anteriores a esta modificación, debemos instalar desde las fuentes.

Limpiar las librerías

No olvidemos antes desinstalar la versión obsoleta con

apt remove obs-studio
apt remove libobs0

Seguimos estas instrucciones, donde básicamente bajamos la última versión con Git y la compilamos.

USE_SSL

Hay un par de detalles a tener en cuenta, lo primero es que a la hora de compilar con cmake hay que pasarle el parámetro -DUSE_SSL=ON para que lo compile con soporte para SSL.

cmake -DUNIX_STRUCTURE=1 -DCMAKE_INSTALL_PREFIX=/usr -DUSE_SSL=ON ..

CMAKE 3.1 / 3.7

En Etertics Kuntur, la versión de cmake es 3.7. Pero cuando llegamos al paso de compilar con make -j4 dice que necesita ser compilado con la 3.1 (!).

CMake 3.10 or higher is required. You are running version 3.7.2
-- Configuring incomplete, errors occurred!

Así se puede descargar para disponibilizarla a nuestra terminal:

curl -LO -# https://cmake.org/files/v3.10/cmake-3.10.3-Linux-x86_64.tar.gz
tar -xf cmake-3.10.3-Linux-x86_64.tar.gz
export PATH=$(pwd)/cmake-3.10.3-Linux-x86_64/bin:$PATH 

Ahora sí funciona, esta es la línea relevante en el log:

-- Found MbedTLS
checkinstall

Finalmente checkinstall hace el makeinstall y además genera un paquete .deb Pero se caía al final, porque colisionaba con paquetes de la versión anterior, hay que cerciorarse de haberlos desinstalado con apt remove libobs0

Done. The new package has been installed and saved to
/opt/obs-studio/build/obs-studio_20201024-git-1_amd64.deb
You can remove it from your system anytime using:
dpkg -r obs-studio

Este sitio utiliza cookies.    Leer más
Privacidad